Aller au contenu principal
loading

phpize - autom4te: need GNU m4 1.4 or later: /Applications/MAMP/Library/bin/m4

POSTÉ DANS Docker TAGS Serveur AUTEUR herve COMMENTAIRES 0

autom4te: need GNU m4 1.4 or later: /Applications/MAMP/Library/bin/m4

Il est possible que vous ayiez l'erreur suivante en lançant une commande qui utilise phpize : 

autom4te: need GNU m4 1.4 or later: /Applications/MAMP/Library/bin/m4

 Cela est dû au fait que MAMP utilise ses propres fichiers, et que /Applications/MAMP/bin/php/php7.2.8/bin/phpize utilise toujours /Applications/MAMP/Library/bin/m4

Pour résoudre ça :

  • brew install m4
  • mv /Applications/MAMP/Library/bin/m4 /Applications/MAMP/Library/bin/m4_backup
  • ln -s /usr/local/opt/m4/bin/m4 /Applications/MAMP/Library/bin/m4
  • votre commande avec phpize
  • unlink /Applications/MAMP/Library/bin/m4
  • mv /Applications/MAMP/Library/bin/m4_backup /Applications/MAMP/Library/bin/m4


0 commentaire

Derniers articles

Erreur DOCKSAL_NFS_PATH sous Mac OS X
Erreur DOCKSAL_NFS_PATH sous Mac OS X Posté le 11 août 2021
DDEV : obtenir la liste des services
DDEV : obtenir la liste des services Posté le 27 janvier 2021
Partager un répertoire local sous Docker
Partager un répertoire local sous Docker Posté le 27 janvier 2021
Docker et Localhost Mac
Docker et Localhost Mac Posté le 27 janvier 2021

A propos de Web'Up